Léo Corporation Status

Xalyus Store cannot download any apps

Resolved
Xalyus Store
Partial Outage

When downloading an application in Xalyus Store, the app crashes.

2022-02-18T11:19:40.769Z
Resolved

A fix for Xalyus Store is now rolling out to everyone. Thanks for your patience. Note that if cannot install it, we strongly recommand you reinstall Xalyus Store by downloading it again here.

2022-02-18T08:55:19.184Z
Monitoring

We found the cause of the issue and we are working on a fix. Howerver, it might get released later this day. You can use our website to download our apps if needed.