Léo Corporation Status

DNS change

Resolved
Web Experiences
Under Maintenance

We are making some changes in our DNS configuration. Some of our subdomains may not be available.

2023-03-22T13:32:33.091Z
Resolved

We have successfully removed one of our DNS record pointing to a development URL.